After upgrading from 3.8.3 to 4.5

After deploying the latest ServiceControl v4.5, from 3.5 version, as was advised from the online documentation, to go from 3.5 to 4.5, one must upgrade to 3.8.3 first, then apply the 4.5 upgrade after. Which is how the monitoring is at, at the moment.

However, am getting the feedback from developers

  1. that sometimes message headers and body is missing.

  1. from the configuration setup, the end points do not work - the workaround was to use the full CNAME alias

    Everything else is up and running.

Can you advise on the following, as we have paid for customer support?

  • Is it a pre-requisite to clear down the database prior to doing the upgrade from 3.8.3 to 4.5?
  • Should localhost:33333 be working from the configuration setting as shown above? It did work previously by updating the app.constants.js found under ServicePulse which is hosted in IIS using the reverse proxy to authenticate domain users.
  • Would updating to 4.5.2 which is the latest, resolve the issue?

We’re running ServiceControl v4.5 and ServicePulse v1.23.0 and have a commercial/enterprise license as shown

image

Thanks

CHeck if all error and audit instances are running. As you have updated the hostnames it seems it might be that the error instance configuration contains incorrect values. Please navigate to the error instance installation folder and open the configuration file. It is are audit instances listed including hostnames. You might need to update these manually.

No, this is not required.

The hostname should be used that is listed in the ServiceControl Management Utility. However, you are using IIS ARR. In SP you should use the IIS hostname if you need to connect via IIS.

Here you can see the releases including their release notes.

Can confirm as shown

Configuration is as shown:

Can you clarify what you meant?

Clicking on the gear wheel yields this

Made an adjustment to the connections tab page as shown and that works rather than using just /api and /monitoring

To furnish further, this is intermittent and appears to spam the events

Am suspecting that the config setting for the Remotes is malformed?

The key “ServiceControl/RemoteInstances” currently has the value “localhost” you need to specify the actual hostname as also used in your ServicePulse settings. These should be aligned.

Has your issue been resolved?