No handlers could be found for message type


(Marco Encarnacao) #1

Hi there,

I’m currently getting that exception and I can’t find what the problem is.
I’m using convention base configuration and this us something which was working before, but in order to debug the issue, I marked the event with IEvent which did not fixed the issue. I then created a new event with no registered handlers, using the convention configuration and it worked as expected. Last thing I did was changing the original faulty event name and it worked.

I can’t understand what the issue is but it seems something more deep. I am using the latest NServiceBus packages with RabbitMQ

Thanks in advance.


(Marco Encarnacao) #2

I tried to debug the issue a bit further, I deleted all the queues/exchanges and it is now working normally… Since NServicebus creates all the subscriptions is this a NServiceBus or RabbitMq issue?

Thanks


(Marco Encarnacao) #3

I found what the issue was - I deleted a saga which was handling the original event and the subscription was still in the exchange. It just think that in the case the error message should be a bit more explicit.

Thanks anyway.


(Andreas Öhlund) #4

just think that in the case the error message should be a bit more explicit.

What would you like to see in that message to make this more clear?


(Marco Encarnacao) #5

We know we are using a native subscription model, in this case RabbitMQ, so in this case we could have a specific exception per transport and that exception could say something like: The subscription (handlerType) defined in the exchange xxxx could not be found.

Thanks Andrea