Using MSMQ across several machines


(Allan Michaelsen) #1

Hi All
I’m using MSMQ transport for my project and have hit a dead stop…

My project uses microservices for backend and WPF applications for frontend.
When I run it on my development machine internally all is well (mostly, some lag when publishing high volume messages), but when I move my applications to another machine for testing, no messages get through. I’ve checked my MSMQ config and believe it to be okay (running in workstation mode, setup with the powershell scripts), I’ve placed the “instance-mapping.xml” file in the root of my project folder and when the app starts up it logs the routing and configured, but still no messages com across the network.
I’ve disabled the firewall on both the “backend” and the “terminal” for testing purposes, but same result.

Any ideas as to how I can debug this issue?

(Michal Wojcik) #2

Hi Allan,

Without asking questions I would advice to look at this documentation about troubleshooting issues related to MSMQ:

Especially the second point about messages being stuck can give you some insight on what is happening.