Disable SQS Queue Creation with Service Control Transport Adapter

servicecontrol
nservicebus
sqs

(Jimmy Fitzgerald) #1

Hello,

We are using a service control transport adapter to handle messages with AWS/SQS. Is it possible to disable queue creation when using SqsSTransport for service control?

We can disable on other services\endpoints through DisableInstallers(), but do not see an equivalent on the TransportAdapterConfig or through the CustomizeEndpointTransport callback. Is it possible to do something like this?

We also tried to set through SettingsHolder but it didnt seem to take effect (not sure if this is supported or even the correct setting). transport.GetSettings().Set("Transport.CreateQueues", false)

NServiceBus 6x is being used in this setup.

Thanks
Jimmy


(Daniel Marbach) #2

Hi Jimmy

Can you try

transport.GetSettings().Set("NServiceBus.Raw.CreateQueue", false);

?

Although I have a hunch we might have an ordering issue. @SzymonPobiega can you confirm?

Regards
Daniel


(Jimmy Fitzgerald) #3

Daniel,

Still no luck, the queues are created in AWS with that setting set to false.

Jimmy


(Daniel Marbach) #4

Hi Jimmy

I raised an issue https://github.com/Particular/ServiceControl.TransportAdapter/issues/26 as well as a potential fix https://github.com/Particular/ServiceControl.TransportAdapter/pull/27

Regards
Daniel


(Jimmy Fitzgerald) #5

Daniel,

Thanks, we will keep an eye on the referenced issue/pull.

Jimmy


(Daniel Marbach) #6

Hi Jimmy

The issue is fixed, have a look at ServiceControl.TransportAdapter 1.2.3 - Patch release available

Regards
Daniel


(Jimmy Fitzgerald) #7

Daniel,

Thank you so much, we updated and queue creation can be disabled. We appreciate the quick responses/fix!

Jimmy