Queue not getting published to rabbitmq and handler not getting hit though there is queue after upgrading nservicebus.rabbitmq version from 5.1.2 to 7.0.4

existing solution which worked with nservicebus.rabbitmq version as 5.1.2. after upgrading to 7.0.4 queue is not pushed to rabbitmq and if rabbit mq has a queue its not getting picked by the handler.
dont see any exception log. solution is able to connect to rabbitmq and get the queue but handler not getting hit.

    <PackageReference Include="NServiceBus" Version="7.8.2" />
<PackageReference Include="NServiceBus.RabbitMQ" Version="7.0.4" />

I’m sorry, but it is not entirely clear what your issue is.

What do you mean with queue is not pushed to RabbitMQ? Do you mean the queue is not created by the endpoint?

Do you see the message in the queue? Can you verify if the queue mentioned in the diagnostics file corresponds with the queue you are investigating?

This is dotnet core 3.1 application. which is working perfect with below nservicebus packages.

PackageReference Include=“NServiceBus” Version=“7.1.9” /
PackageReference Include=“NServiceBus.RabbitMQ” Version=“5.1.2” /

due to some reasons we have to upgrade solution to dotnet 6 and that made me upgrade nservicebus versions too.

PackageReference Include=“NServiceBus” Version=“7.8.2” /
PackageReference Include=“NServiceBus.RabbitMQ” Version=“7.0.4” /

apart from version changes made 3 more other code changes related to nservicebus

So after upgrade i am facing 2 challenges.

  1. application is able to make a connection with rabbitmq server and i can see the queue with one message in the connection object but handler is not getting hit
  2. when i try to send a new message to queue its not getting added to rabbitmq server queue.

since i am not seeing any exception in console couldnt figure out what exactly missing.

Yes i am checking the same rabbitmq queue there is message.

so i tried upgrading only nservicebus in 3.1 dotnet solution then its working good again if i change nservicebus.rabbitmq its asking for extra 3 changes which i added above after doing that same 2 issues i am seeing with 3.1 solution too. so i am suspecting something with nservicebus.rabbitmq version. i tried figuring out unfortunately couldnt. i am not sure if any other dependencies there with the new version of rabbitmq which i am missing to add.

Could it be that you get an exception? How are you sending that message?

Latest version of NServiceBus.RabbitMQ is 7.0.5 but hotfix does not seem to be applying to your problem.

Can you share the log and diagnostics files? Please review and remove any sensitive information from these.