ServicePulse starts with blank screen

I am trying to get ServicePulse working on my server . On my windows development machine (Windows 10) it runs without problems.
When I take the exact same installation to a Windows 2019 server, ServiceControl management and Service Insight run without a problem. However, the ServicePulse webapplication starts without errors and only presents a blank screen. The title is visible in the address tab but no data. I tried it on 2 servers and with different browsers. All the same result.

If anyone has an idea, I would be thrilled to here it.

Kind regards

What versions of ServicePulse and ServiceControl are you using?

Do you have any browser extensions that could be preventing certain resources to be loaded?

Which browsers did you test? We do not support Internet Explorer

If you open the browser development tools does the console or network tab provide any details?


I installed the latest version of ServicePulse (1.36.4)
It installed without problems and is running under local service.
The machine is a windows server 2019 .
I use the simple installed chrome as browser. (65.0.3325.181).
In the browser now I see in the Console an uncaught SyntaxError : Unexpected token { in :8081/assets/index…
In the network tab only 1 line (no error) : http://localhost:8081/assets/index.1939d7c1.js

I started the in a command window with administrative rights.

EDIT: ServiceControl version is 4.30.1

Hi Robert,

I created a fresh virtual machine with Windows 2019 Datacenter and was able to get ServicePulse 1.37.0 working in Edge and Chrome without any issues.

Is there a reason you are running the host manually? The installer will set it up as a windows service.